Skip to main content
← All vulnerabilities
CVE-2020-36193GHSA-RPW6-9XFX-JVCXBIT-DRUPAL-2020-36193

Tar.php in Archive_Tar through 1.4.11 allows write operations with Directory Traversal due to inadequate checking of symbolic links, a relat

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 1.4.13
None on Exploit-DB, Metasploit or GitHub

Summary

Archive_Tar, a PHP library for creating and extracting tar archives, is affected by this vulnerability. An attacker could craft a malicious archive that writes files outside the intended extraction directory, potentially overwriting sensitive files on the system.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Tar.php in Archive_Tar through 1.4.11 allows write operations with Directory Traversal due to inadequate checking of symbolic links, a related issue to CVE-2020-28948.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • n/a n/a

    Version range not reported

  • pear/archive_tarPackagist

    fixed in 1.4.13

References 10

GitHub · pear/Archive_Tar

drupal.org

lists.debian.org

security.gentoo.org

lists.fedoraproject.org

debian.org

FAQ

Questions about CVE-2020-36193

What does this mean?

Archive_Tar's Tar.php does not properly check symbolic links when writing extracted files. A crafted archive can therefore write files outside the intended directory, which is a directory traversal.Source: security.gentoo.org, lists.fedoraproject.org

Am I affected, and how do I check?

The listed range is pear/archive_tar through 1.4.11. One listed package, dev-php/PEAR-Archive_Tar, is described as affected on all architectures below 1.4.12. To check an installed copy, look at the Archive_Tar version reported by PEAR or your package manager.Source: security.gentoo.org, lists.fedoraproject.org

What should I do about it?

Upgrade Archive_Tar to 1.4.13, the fixed version in the product range data. The condition text gives 1.4.12 as the cutoff, so confirm the exact target against the advisory before choosing a version.Source: security.gentoo.org, lists.fedoraproject.org

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-08-25, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data