An issue was discovered on D-Link DCS-2530L before 1.06.01 Hotfix and DCS-2670L through 2.02 devices.
Affects D-Link DCS-2530L firmware v1.05.05 and older and DCS-2670L firmware v2.02 and older. The listed fix is DCS-2530L v1.07.00 Hotfix.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in v1.07.00 Hotfix
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The affected software is the firmware on D-Link DCS-2530L and DCS-2670L camera devices. An attacker who can reach the device over the network can retrieve the administrator password without logging in, because a web endpoint does not require authentication.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
An issue was discovered on D-Link DCS-2530L before 1.06.01 Hotfix and DCS-2670L through 2.02 devices. The unauthenticated /config/getuser endpoint allows for remote administrator password disclosure.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- n/a n/a
Version range not reported
References 2
supportannouncement.us.dlink.com
twitter.com
Questions about CVE-2020-25078
What does this mean?
An unauthenticated attacker can reveal the administrator password on the device.Source: supportannouncement.us.dlink.com
Am I affected, and how do I check?
The listed affected builds are DCS-2530L firmware v1.05.05 and older and DCS-2670L firmware v2.02 and older. Compare the device's firmware version with these listed versions.Source: supportannouncement.us.dlink.com
What should I do about it?
For DCS-2530L, the listed fix is v1.07.00 Hotfix. The source does not list a fixed version for DCS-2670L.Source: supportannouncement.us.dlink.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-08-05, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data