The Widget Connector macro in Atlassian Confluence Server before version 6.6.12 (the fixed version for 6.6.x), from version 6.7.0 before 6.1
The Widget Connector macro in Confluence Server and Data Center is affected in several 6.x branches. Fixed in 6.6.12, 6.12.3, 6.13.3 and 6.14.2.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 6.6.12, 6.12.3, 6.13.3, 6.14.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Atlassian Confluence Server and Data Center instances are affected through the Widget Connector macro, which allows remote attackers to traverse file paths and execute arbitrary code on the server. The impact is full compromise of the affected Confluence server, since an attacker can run commands on it without logging in.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
The Widget Connector macro in Atlassian Confluence Server before version 6.6.12 (the fixed version for 6.6.x), from version 6.7.0 before 6.12.3 (the fixed version for 6.12.x), from version 6.13.0 before 6.13.3 (the fixed version for 6.13.x), and from version 6.14.0 before 6.14.2 (the fixed version for 6.14.x), allows remote attackers to achieve path traversal and remote code execution on a Confluence Server or Data Center instance via server-side template injection.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- Atlassian Confluence Server
From unspecified · fixed in 6.6.12; From 6.7.0 · fixed in unspecified; From unspecified · fixed in 6.12.3; From next of 6.13.0 · fixed in unspecified; From unspecified · fixed in 6.13.3; From next of 6.14.0 · fixed in unspecified; From unspecified · fixed in 6.14.2
References 5
jira.atlassian.com
packetstormsecurity.com
Exploit-DB
Questions about CVE-2019-3396
What does this mean?
The Widget Connector macro has a server-side template injection flaw. The vendor says it can lead to path traversal and remote code execution on the server.Source: jira.atlassian.com
Am I affected, and how do I check?
Confluence Server and Data Center versions before 6.6.12, from 6.7.0 before 6.12.3, from 6.13.0 before 6.13.3, and from 6.14.0 before 6.14.2 are affected. To check a version, look at the version shown in the Confluence administration pages.Source: jira.atlassian.com
What should I do about it?
Upgrade to 6.6.12, 6.12.3, 6.13.3 or 6.14.2, whichever matches your release line. Confluence Server 6.6.12 is available from Atlassian's download archives.Source: jira.atlassian.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2021-11-03, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data