In the Linux kernel before 5.1.17, ptrace_link in kernel/ptrace.c mishandles the recording of the credentials of a process that wants to cre
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 4.19.37-5+deb10u1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The Linux kernel, the core operating system software used across many servers, desktops, and devices, is affected. A local user on a vulnerable system could exploit this flaw to gain root (full administrator) control of the machine.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
In the Linux kernel before 5.1.17, ptrace_link in kernel/ptrace.c mishandles the recording of the credentials of a process that wants to create a ptrace relationship, which allows local users to obtain root access by leveraging certain scenarios with a parent-child process relationship, where a parent drops privileges and calls execve (potentially allowing control by an attacker). One contributing factor is an object lifetime issue (which can also cause a panic). Another contributing factor is incorrect marking of a ptrace relationship as privileged, which is exploitable through (for example) Polkit's pkexec helper with PTRACE_TRACEME. NOTE: SELinux deny_ptrace might be a usable workaround in some environments.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- n/a n/a
Version range not reported
References 25
packetstormsecurity.com
bugs.chromium.org
cdn.kernel.org
GitHub · torvalds/linux
git.kernel.org
bugzilla.suse.com
bugzilla.redhat.com
lists.fedoraproject.org
debian.org
seclists.org
security.netapp.com
access.redhat.com
support.f5.com
Questions about CVE-2019-13272
What does this mean?
The ptrace_link function in the Linux kernel mishandles how it records the credentials of a process that wants to create a ptrace relationship. This lets a local user obtain root privileges under certain scenarios, which the advisory does not detail.Source: lists.debian.org
Am I affected, and how do I check?
The description names Linux kernel versions before 5.1.17. The advisory does not specify the exact scenarios needed to trigger the flaw. To check a system's kernel version, run uname -r.Source: lists.debian.org
What should I do about it?
The fix is available in package version 4.19.37-5+deb10u1, so install that version or a later one. No workaround is listed in the facts.Source: lists.debian.org
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2021-12-10, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data