Citrix SD-WAN 10.2.x before 10.2.3 and NetScaler SD-WAN 10.0.x before 10.0.8 have Improper Input Validation (issue 5 of 6).
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 10.0.8, 10.2.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Citrix SD-WAN and NetScaler SD-WAN software are affected by this vulnerability, which stems from improper input validation. An attacker who exploits it could potentially compromise the affected system, though the specific impact is not detailed in the available description.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Citrix SD-WAN 10.2.x before 10.2.3 and NetScaler SD-WAN 10.0.x before 10.0.8 have Improper Input Validation (issue 5 of 6).
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- n/a n/a
Version range not reported
References 4
tenable.com
securityfocus.com
packetstormsecurity.com
support.citrix.com
Questions about CVE-2019-12991
What does this mean?
The flaw is improper input validation in the installfile parameter of the installpatch.cgi script. An attacker who can send a crafted request to it can run operating system commands with root privileges.Source: tenable.com
Am I affected, and how do I check?
Citrix SD-WAN 10.2.x before 10.2.3 and NetScaler SD-WAN 10.0.x before 10.0.8 are listed as affected. To check a device, compare its SD-WAN version against these ranges.Source: tenable.com
What should I do about it?
Upgrade to 10.0.8 for NetScaler SD-WAN 10.0.x or to 10.2.3 for Citrix SD-WAN 10.2.x, as the vendor's security update specifies.Source: tenable.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-03-25, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data