Atlassian Crowd and Crowd Data Center had the pdkinstall development plugin incorrectly enabled in release builds.
Affects Crowd and Crowd Data Center release builds with the pdkinstall development plugin enabled, in releases from 2.1.0 before the fixed versions 3.0.5, 3.1.6, 3.2.8, 3.3.5, and 3.4.4. Fixed in 3.4.4.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 3.0.5, 3.1.6, 3.2.8, 3.3.5, 3.4.4
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Atlassian Crowd and Crowd Data Center are affected by this vulnerability. An attacker who can send requests to a Crowd or Crowd Data Center instance could install arbitrary plugins, which would allow remote code execution on the affected server.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Atlassian Crowd and Crowd Data Center had the pdkinstall development plugin incorrectly enabled in release builds. Attackers who can send unauthenticated or authenticated requests to a Crowd or Crowd Data Center instance can exploit this vulnerability to install arbitrary plugins, which permits remote code execution on systems running a vulnerable version of Crowd or Crowd Data Center. All versions of Crowd from version 2.1.0 before 3.0.5 (the fixed version for 3.0.x), from version 3.1.0 before 3.1.6 (the fixed version for 3.1.x), from version 3.2.0 before 3.2.8 (the fixed version for 3.2.x), from version 3.3.0 before 3.3.5 (the fixed version for 3.3.x), and from version 3.4.0 before 3.4.4 (the fixed version for 3.4.x) are affected by this vulnerability.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- Atlassian Crowd
From 2.1.0 · fixed in unspecified; From unspecified · fixed in 3.0.5; From 3.1.0 · fixed in unspecified; From unspecified · fixed in 3.1.6; From 3.2.0 · fixed in unspecified; From unspecified · fixed in 3.2.8; From 3.3.0 · fixed in unspecified; From unspecified · fixed in 3.3.5; From 3.4.0 · fixed in unspecified; From unspecified · fixed in 3.4.4
References 3
jira.atlassian.com
securityfocus.com
packetstormsecurity.com
Questions about CVE-2019-11580
What does this mean?
The pdkinstall development plugin was incorrectly left enabled in Crowd and Crowd Data Center release builds. This lets arbitrary plugins be installed, which permits remote code execution on the affected system.Source: jira.atlassian.com
Am I affected, and how do I check?
Affected versions are Crowd 2.1.0 before 3.0.5, 3.1.0 before 3.1.6, 3.2.0 before 3.2.8, 3.3.0 before 3.3.5, and 3.4.0 before 3.4.4. Check the Crowd version, and look for pdkinstall-plugin jar files in the Crowd installation directory and the data directory.Source: jira.atlassian.com
What should I do about it?
Upgrade to Crowd or Crowd Data Center 3.4.4, available from the Atlassian download page, or to the fixed release for your branch (3.0.5, 3.1.6, 3.2.8, or 3.3.5).Source: jira.atlassian.com
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2021-11-03, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data