Skip to main content
← All vulnerabilities
CVE-2019-1003030GHSA-R6MC-MRVR-23CR

A sandbox bypass vulnerability exists in Jenkins Pipeline: Groovy Plugin 2.63 and earlier in pom.xml, src/main/java/org/jenkinsci/plugins/wo

Affects Jenkins Pipeline: Groovy Plugin 2.63 and earlier, where users allowed to control pipeline contents can bypass the sandbox. The package workflow-cps is fixed in 2.64.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 2.64
None on Exploit-DB, Metasploit or GitHub

Summary

The Jenkins Pipeline: Groovy Plugin is affected by a sandbox bypass flaw. An attacker who can control pipeline scripts could use it to run arbitrary code on the Jenkins master server.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

A sandbox bypass vulnerability exists in Jenkins Pipeline: Groovy Plugin 2.63 and earlier in pom.xml, src/main/java/org/jenkinsci/plugins/workflow/cps/CpsGroovyShell.java that allows attackers able to control pipeline scripts to execute arbitrary code on the Jenkins master JVM.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Jenkins project Jenkins Pipeline: Groovy Plugin

    2.63 and earlier

  • org.jenkins-ci.plugins.workflow:workflow-cpsMaven

    fixed in 2.64

References 4

jenkins.io

securityfocus.com

access.redhat.com

packetstormsecurity.com

FAQ

Questions about CVE-2019-1003030

What does this mean?

Users who are allowed to control the contents of a Jenkins pipeline can bypass the sandbox protection. The bypass lets them execute arbitrary code on the Jenkins controller (master JVM).Source: jenkins.io

Am I affected, and how do I check?

The advisory covers Jenkins Pipeline: Groovy Plugin version 2.63 and earlier. The affected package is org.jenkins-ci.plugins.workflow:workflow-cps, with versions before 2.64. Check the installed plugin versions in the Jenkins plugin manager.Source: jenkins.io

What should I do about it?

Upgrade the workflow-cps package to version 2.64 or later.Source: jenkins.io

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-03-25, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data