A sandbox bypass vulnerability exists in Jenkins Script Security Plugin 1.53 and earlier in src/main/java/org/jenkinsci/plugins/scriptsecuri
Affects Jenkins Script Security Plugin 1.53 and earlier, including script execution invoked from other plugins and an HTTP script validation endpoint. Fixed in 1.54. CVSS rates it critical (9.9).
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 1.54
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The Jenkins Script Security Plugin, which sandboxes Groovy scripts, contains a flaw that lets users with only basic read access run arbitrary code on the Jenkins master server. A successful attack could give an attacker full control over the Jenkins controller and the systems it manages.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
A sandbox bypass vulnerability exists in Jenkins Script Security Plugin 1.53 and earlier in src/main/java/org/jenkinsci/plugins/scriptsecurity/sandbox/groovy/GroovySandbox.java, src/main/java/org/jenkinsci/plugins/scriptsecurity/sandbox/groovy/SecureGroovyScript.java that allows attackers with Overall/Read permission to execute arbitrary code on the Jenkins master JVM.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- Jenkins project Jenkins Script Security Plugin
1.53 and earlier
- org.jenkins-ci.plugins:script-securityMaven
fixed in 1.54
References 4
securityfocus.com
access.redhat.com
packetstormsecurity.com
Questions about CVE-2019-1003029
What does this mean?
A crafted Groovy script can get around the Script Security sandbox during parsing, compilation, and script instantiation. Users with Overall/Read permission can then run arbitrary code on the Jenkins controller.Source: jenkins.io
Am I affected, and how do I check?
The Jenkins Script Security Plugin (org.jenkins-ci.plugins:script-security) version 1.53 and earlier is affected, covering both script execution invoked from other plugins and the HTTP script validation endpoint. To check the installed version, look at the plugin list in the Jenkins plugin manager.Source: jenkins.io
What should I do about it?
Upgrade the Script Security Plugin to version 1.54 or later.Source: jenkins.io
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-04-25, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data