Skip to main content
← All vulnerabilities
CVE-2018-14634

An integer overflow flaw was found in the Linux kernel's create_elf_tables() function.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in kernel-3.10.0-514.61.1.el7
None on Exploit-DB, Metasploit or GitHub

Summary

The Linux kernel is affected, specifically its ELF binary loading code in create_elf_tables(). A local user with low privileges could potentially use this flaw to gain higher privileges on the system.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

An integer overflow flaw was found in the Linux kernel's create_elf_tables() function. An unprivileged local user with access to SUID (or otherwise privileged) binary could use this flaw to escalate their privileges on the system. Kernel versions 2.6.x, 3.10.x and 4.14.x are believed to be vulnerable.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. Record last updated
  4. CISA remediation deadline

    Due date for US federal agencies to patch

  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • The Linux Foundation kernel

    2.6.x, 3.10.x, 4.14.x

References 22

access.redhat.com

security.netapp.com

Exploit-DB

usn.ubuntu.com

securityfocus.com

openwall.com

bugzilla.redhat.com

support.f5.com

security.paloaltonetworks.com

FAQ

Questions about CVE-2018-14634

What should I do about it?

Update the Linux kernel to kernel-3.10.0-514.61.1.el7 or later, which is the fixed version listed for this vulnerability. No workaround is listed in the checked facts.Source: access.redhat.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-01-26, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data