Skip to main content
← All vulnerabilities
CVE-2016-7892

Adobe Flash Player versions 23.0.0.207 and earlier, 11.2.202.644 and earlier have an exploitable use after free vulnerability in the TextFie

Affects Adobe Flash Player 23.0.0.207 and earlier, and 11.2.202.644 and earlier, on supported Windows editions and Gentoo. No vendor rating is given. Fixed in 24.0.0.186.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 24.0.0.186
None on Exploit-DB, Metasploit or GitHub

Summary

Adobe Flash Player, a browser plugin for running multimedia content, is affected by this flaw. A successful attack could allow an attacker to run arbitrary code on the affected computer.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Adobe Flash Player versions 23.0.0.207 and earlier, 11.2.202.644 and earlier have an exploitable use after free vulnerability in the TextField class. Successful exploitation could lead to arbitrary code execution.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • n/a Adobe Flash Player 23.0.0.207 and earlier, 11.2.202.644 and earlier

    Adobe Flash Player 23.0.0.207 and earlier, 11.2.202.644 and earlier

References 8

lists.opensuse.org

docs.microsoft.com

security.gentoo.org

securitytracker.com

rhn.redhat.com

helpx.adobe.com

securityfocus.com

FAQ

Questions about CVE-2016-7892

What does this mean?

A use after free flaw in the TextField component could let a remote attacker possibly execute arbitrary code with the privileges of the Flash Player process, or bypass security restrictions.Source: learn.microsoft.com, security.gentoo.org

Am I affected, and how do I check?

Adobe Flash Player 23.0.0.207 and earlier, and 11.2.202.644 and earlier, when installed on supported Windows editions (Windows 8.1, Windows Server 2012, Windows RT 8.1, Windows 10, Windows Server 2016). On Gentoo, www-plugins/adobe-flash on all architectures before 24.0.0.186 is listed. Check the installed Flash Player version, or the installed www-plugins/adobe-flash package version on Gentoo.Source: learn.microsoft.com, security.gentoo.org

What should I do about it?

Update Flash Player to 24.0.0.186 or later. On Gentoo, upgrade www-plugins/adobe-flash to 24.0.0.186 or later.Source: learn.microsoft.com, security.gentoo.org

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-03-25, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data