The Array.prototype.concat implementation in builtins.cc in Google V8, as used in Google Chrome before 49.0.2623.108, does not properly cons
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- How many real-world setups can hit the bug, from the vendor's advisory and CISA data. It does not know your setup.What do these mean? →
- Actively exploited
- Fix
- Fixed in 50.0.2661.102
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The Google Chrome web browser, specifically its V8 JavaScript engine, is affected in versions before 49.0.2623.108. A remote attacker who gets a user to run crafted JavaScript could crash the browser through an out-of-bounds memory read, and may be able to have other unspecified effects.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
The Array.prototype.concat implementation in builtins.cc in Google V8, as used in Google Chrome before 49.0.2623.108, does not properly consider element data types, which allows remote attackers to cause a denial of service (out-of-bounds read) or possibly have unspecified other impact via crafted JavaScript code.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- n/a n/a
Version range not reported
References 11
rhn.redhat.com
lists.opensuse.org
googlechromereleases.blogspot.com
debian.org
codereview.chromium.org
securitytracker.com
code.google.com
ubuntu.com
security.gentoo.org
Questions about CVE-2016-1646
What does this mean?
Array.prototype.concat did not work correctly with complex elements on the receiver or the prototype chain. The advisory's general impact text says a remote attacker could possibly execute arbitrary code with the privileges of the process, cause a Denial of Service, obtain sensitive information, or bypass security restrictions.Source: codereview.chromium.org, security.gentoo.org
Am I affected, and how do I check?
The bug involves Array.prototype.concat being used with complex elements on the receiver or the prototype chain. To check a Chrome install, look up its version in the browser's About page or with the package manager's version query.Source: codereview.chromium.org, security.gentoo.org
What should I do about it?
The listed fix is version 50.0.2661.102, so upgrade to that release or later. No workaround is listed in the facts.Source: codereview.chromium.org, security.gentoo.org
Is it being exploited?
Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-06-08, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data