Skip to main content
← All vulnerabilities
CVE-2016-10033GHSA-5F37-GXVH-23V6

The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow remote attackers to pass extra parameters to the mail c

PHPMailer versions before 5.2.18 are affected when they use the default PHP mail() transport (isMail). The fix is in PHPMailer 5.2.18.

Published
Last modified
published
Listed in CISA KEV
Actively exploited
Fix
Fixed in 5.2.18
None on Exploit-DB, Metasploit or GitHub

Summary

PHPMailer, a popular PHP library for sending email, is affected through its isMail transport, where the mailSend function may let remote attackers inject extra parameters into the mail command. This could allow an attacker to execute arbitrary code on the server hosting the application.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow remote attackers to pass extra parameters to the mail command and consequently execute arbitrary code via a \" (backslash double quote) in a crafted Sender property.

Timeline

  1. CVE published
  2. Added to CISA KEV

    CISA has evidence of exploitation in the wild

  3. CISA remediation deadline

    Due date for US federal agencies to patch

  4. Record last updated
  5. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • n/a n/a

    Version range not reported

  • phpmailer/phpmailerPackagist

    From 5.0.0 · fixed in 5.2.18

References 21

packetstormsecurity.com

drupal.org

Exploit-DB

legalhackers.com

GitHub · PHPMailer/PHPMailer

securityfocus.com

rapid7.com

seclists.org

securitytracker.com

developer.joomla.org

FAQ

Questions about CVE-2016-10033

What does this mean?

The mailSend function in the isMail transport can let remote attackers pass extra parameters to the mail command. The vendor describes the impact as remote arbitrary code execution as the web server user, which could lead to full compromise of the web application.Source: drupal.org, legalhackers.com

Am I affected, and how do I check?

PHPMailer versions from 5.0.0 up to but not including 5.2.18 are affected, in setups where PHPMailer uses the PHP mail() function as its default transport. To check, look at the installed phpmailer/phpmailer version and whether the transport is still the default PHP mail() function.Source: drupal.org, legalhackers.com

What should I do about it?

Upgrade PHPMailer to version 5.2.18, which the vendor released as a critical security release to fix the issue.Source: drupal.org, legalhackers.com

Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-07-07, which means it has evidence of attacks. No public exploit code is tracked.Source: cisa.gov, cve.now feed data