Skip to main content
← RubyGems

webrick

5 known vulnerabilities (1 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
5 · 1 medium
Registry
RubyGems

Advisories 5

  • CVE-2025-6442Medium 6.5

    Ruby WEBrick read_header HTTP Request Smuggling Vulnerability

    Affected: fixed in 1.8.2.

  • An issue was discovered in Ruby through 2.5.8, 2.6.x through 2.6.6, and 2.7.x through 2.7.1.

    Affected: from 1.6.0, fixed in 1.6.1; from 1.5.0, fixed in 1.5.1; fixed in 1.4.4.

  • The Basic authentication code in WEBrick library in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows remote attackers…

    Affected: fixed in 1.4.0.

  • WEBrick 1.3.1 in Ruby 1.8.6 through patchlevel 383, 1.8.7 through patchlevel 248, 1.8.8dev, 1.9.1 through patchlevel 376, and 1.9.2dev…

    Affected: fixed in 1.4.0.

  • httputils.rb in WEBrick in Ruby 1.8.1 and 1.8.5, as used in Red Hat Enterprise Linux 4 and 5, allows remote attackers to cause a denial of…

    Affected: fixed in 1.3.1.