Skip to main content
← RubyGems

rails_admin

4 known vulnerabilities (2 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
4 · 2 medium
Registry
RubyGems

Advisories 4

  • CVE-2024-39308Medium 6.8

    RailsAdmin Cross-site Scripting vulnerability in the list view

    Affected: from 3.0.0.beta, fixed in 3.1.3.

  • RailsAdmin (aka rails_admin) before 1.4.3 and 2.x before 2.0.2 allows XSS via nested forms.

    Affected: fixed in 1.4.3; from 2.0.0, fixed in 2.0.2.

  • rails_admin ruby gem <v1.1.1 is vulnerable to cross-site request forgery (CSRF) attacks.

    Affected: from 1.0.0, fixed in 1.1.1.

  • CVE-2017-12098Medium 6.1

    An exploitable cross site scripting (XSS) vulnerability exists in the add filter functionality of the rails_admin rails gem version 1.2.0.

    Affected: fixed in 1.3.0.