# publify\_core (RubyGems) vulnerabilities

15 known vulnerabilities (2 critical, 4 high, 7 medium, 1 low), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://rubygems.org/gems/publify_core

## Advisories (15)

### [CVE-2024-39311](https://cve.now/CVE-2024-39311): Publify Vulnerable To Cross-Site Scripting (XSS) Via Redirects Requiring User Interaction

- Severity: Low 1.8
- Published: Mar 28, 2025
- Affected: fixed in 10.0.2.

### [CVE-2023-0569](https://cve.now/CVE-2023-0569): Weak Password Requirements in publify/publify

- Severity: High 8.1
- Published: Jan 29, 2023
- Affected: fixed in 9.2.10.

### [CVE-2023-0299](https://cve.now/CVE-2023-0299): Improper Input Validation in publify/publify

- Severity: High 8.4
- Published: Jan 14, 2023
- Affected: fixed in 9.2.10.

### [CVE-2022-2815](https://cve.now/CVE-2022-2815): Insecure Storage of Sensitive Information in publify/publify

- Severity: Medium 4.6
- Published: Jan 14, 2023
- Affected: fixed in 9.2.10.

### [CVE-2022-1812](https://cve.now/CVE-2022-1812): Integer Overflow or Wraparound in publify/publify

- Severity: High 7.6
- Published: Jan 14, 2023
- Affected: fixed in 9.2.10.

### [CVE-2022-1811](https://cve.now/CVE-2022-1811): Unrestricted Upload of File with Dangerous Type in publify/publify

- Severity: Critical 9.1
- Published: May 23, 2022
- Affected: fixed in 9.2.9.

### [CVE-2022-1810](https://cve.now/CVE-2022-1810): Authorization Bypass Through User-Controlled Key in publify/publify

- Severity: Critical 9.9
- Published: May 23, 2022
- Affected: fixed in 9.2.9.

### [CVE-2022-1553](https://cve.now/CVE-2022-1553): Leaking password protected articles content due to improper access control in publify/publify

- Severity: High 8.8
- Published: May 16, 2022
- Affected: fixed in 9.2.8.

### [CVE-2022-0578](https://cve.now/CVE-2022-0578): Code Injection in publify/publify

- Severity: Medium 5.3
- Published: May 16, 2022
- Affected: fixed in 9.2.8.

### [CVE-2022-0574](https://cve.now/CVE-2022-0574): Improper Access Control in publify/publify

- Severity: Medium 5.3
- Published: May 16, 2022
- Affected: fixed in 9.2.8.

### [CVE-2022-0524](https://cve.now/CVE-2022-0524): Business Logic Errors in publify/publify

- Severity: Medium 6.5
- Published: Feb 8, 2022
- Affected: fixed in 9.2.7.

### [CVE-2021-25975](https://cve.now/CVE-2021-25975): Publify - Stored Cross-Site Scripting (XSS) due to Unrestricted File Upload

- Severity: Medium 5.4
- Published: Nov 10, 2021
- Affected: from 8.0, fixed in 9.2.5.

### [CVE-2021-25974](https://cve.now/CVE-2021-25974): Publify - Stored Cross-Site Scripting (XSS) in Editor

- Severity: Medium 5.4
- Published: Nov 10, 2021
- Affected: from 8.0, fixed in 9.2.5.

### [CVE-2021-25973](https://cve.now/CVE-2021-25973): Publify - Improper Authorization Leads to Guest Signup Restriction Bypass

- Severity: Medium 6.5
- Published: Nov 2, 2021
- Affected: from 9.0.0.pre1, fixed in 9.2.5.

### [CVE-2014-3211](https://cve.now/CVE-2014-3211): Publify before 8.0.1 is vulnerable to a Denial of Service attack

- Severity: Unrated
- Published: Jan 9, 2020
- Affected: fixed in 8.0.1.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/rubygems/publify_core
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
