# openssl (RubyGems) vulnerabilities

3 known vulnerabilities, with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://rubygems.org/gems/openssl

## Advisories (3)

### [CVE-2018-16395](https://cve.now/CVE-2018-16395): An issue was discovered in the OpenSSL library in Ruby before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.2, and 2.6.x before…

- Severity: Unrated
- Published: Nov 16, 2018
- Affected: fixed in 2.0.9; from 2.1.0, fixed in 2.1.2.

### [CVE-2017-14033](https://cve.now/CVE-2017-14033): The decode method in the OpenSSL::ASN1 module in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows attackers to cause…

- Severity: Unrated
- Published: Sep 19, 2017
- Affected: fixed in 2.0.0.

### [CVE-2016-7798](https://cve.now/CVE-2016-7798): The openssl gem for Ruby uses the same initialization vector (IV) in GCM Mode (aes-\*-gcm) when the IV is set before the key, which makes…

- Severity: Unrated
- Published: Jan 30, 2017
- Affected: fixed in 2.0.0.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/rubygems/openssl
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
