# omniauth (RubyGems) vulnerabilities

3 known vulnerabilities, with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://rubygems.org/gems/omniauth

## Advisories (3)

### [CVE-2020-36599](https://cve.now/CVE-2020-36599): lib/omniauth/failure\_endpoint.rb in OmniAuth before 1.9.2 (and before 2.0) does not escape the message\_key value.

- Severity: Unrated
- Published: Aug 18, 2022
- Affected: fixed in 1.9.2; from 2.0.0.pre.rc1, fixed in 2.0.0.

### [CVE-2015-9284](https://cve.now/CVE-2015-9284): The request phase of the OmniAuth Ruby gem (1.9.1 and earlier) is vulnerable to Cross-Site Request Forgery when used as part of the Ruby…

- Severity: Unrated
- Published: Apr 26, 2019
- Affected: fixed in 2.0.0.

### [CVE-2017-18076](https://cve.now/CVE-2017-18076): In strategy.rb in OmniAuth before 1.3.2, the authenticity\_token value is improperly protected because POST (in addition to GET) parameters…

- Severity: Unrated
- Published: Jan 26, 2018
- Affected: fixed in 1.3.2.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/rubygems/omniauth
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
