Skip to main content
← RubyGems

json-jwt

3 known vulnerabilities (1 high), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
3 · 1 high
Registry
RubyGems

Advisories 3

  • The json-jwt (aka JSON::JWT) gem 1.16.3 for Ruby sometimes allows bypass of identity checks via a sign/encryption confusion attack.

    Affected: from 1.16.0, fixed in 1.16.6; fixed in 1.15.3.1.

  • The json-jwt gem before 1.11.0 for Ruby lacks an element count during the splitting of a JWE string.

    Affected: fixed in 1.11.0.

  • Nov json-jwt version >= 0.5.0 && < 1.9.4 contains a CWE-347: Improper Verification of Cryptographic Signature vulnerability in Decryption…

    Affected: from 0.5.1, fixed in 1.9.4.