# jquery-rails (RubyGems) vulnerabilities

9 known vulnerabilities (2 medium), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://rubygems.org/gems/jquery-rails

## Advisories (9)

### [CVE-2020-7656](https://cve.now/CVE-2020-7656): jquery prior to 1.9.0 allows Cross-site Scripting attacks via the load method.

- Severity: Unrated
- Published: May 19, 2020
- Affected: fixed in 2.2.0.

### [CVE-2020-11023](https://cve.now/CVE-2020-11023): Potential XSS vulnerability in jQuery

- Severity: Medium 6.9 · KEV
- Published: Apr 29, 2020
- Affected: fixed in 4.4.0.

### [CVE-2020-11022](https://cve.now/CVE-2020-11022): jQuery has a potential XSS vulnerability

- Severity: Medium 6.9
- Published: Apr 29, 2020
- Affected: fixed in 4.4.0.

### [CVE-2019-11358](https://cve.now/CVE-2019-11358): jQuery before 3.4.0, as used in Drupal, Backdrop CMS, and other products, mishandles jQuery.extend(true, {}, ...) because of…

- Severity: Unrated
- Published: Apr 19, 2019
- Affected: fixed in 4.3.4.

### [CVE-2016-10707](https://cve.now/CVE-2016-10707): jQuery 3.0.0-rc.1 is vulnerable to Denial of Service (DoS) due to removing a logic that lowercased attribute names.

- Severity: Unrated
- Published: Jan 18, 2018
- Affected: from 3.0.0-rc.1, fixed in 3.0.0.

### [CVE-2015-9251](https://cve.now/CVE-2015-9251): jQuery before 3.0.0 is vulnerable to Cross-site Scripting (XSS) attacks when a cross-domain Ajax request is performed without the dataType…

- Severity: Unrated
- Published: Jan 18, 2018
- Affected: fixed in 4.2.0.

### [CVE-2012-6708](https://cve.now/CVE-2012-6708): jQuery before 1.9.0 is vulnerable to Cross-site Scripting (XSS) attacks.

- Severity: Unrated
- Published: Jan 18, 2018
- Affected: fixed in 2.2.0.

### [CVE-2015-1840](https://cve.now/CVE-2015-1840): jquery\_ujs.js in jquery-rails before 3.1.3 and 4.x before 4.0.4 and rails.js in jquery-ujs before 1.0.4, as used with Ruby on Rails 3.x…

- Severity: Unrated
- Published: Jul 26, 2015
- Affected: fixed in 3.1.3; from 4.0.0, fixed in 4.0.4.

### [CVE-2011-4969](https://cve.now/CVE-2011-4969): Cross-site scripting (XSS) vulnerability in jQuery before 1.6.3, when using location.hash to select elements, allows remote attackers to…

- Severity: Unrated
- Published: Mar 8, 2013
- Affected: fixed in 1.0.16.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/rubygems/jquery-rails
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
