# httparty (RubyGems) vulnerabilities

3 known vulnerabilities (1 high, 1 medium), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://rubygems.org/gems/httparty

## Advisories (3)

### [CVE-2025-68696](https://cve.now/CVE-2025-68696): httparty Has Potential SSRF Vulnerability That Leads to API Key Leakage

- Severity: High 7.8
- Published: Dec 23, 2025
- Affected: fixed in 0.24.0.

### [CVE-2024-22049](https://cve.now/CVE-2024-22049): httparty Multipart/Form-Data Request Tampering Vulnerability

- Severity: Medium 5.3
- Published: Jan 4, 2024
- Affected: through 0.20.0; fixed in 0.21.0.

### [CVE-2013-1801](https://cve.now/CVE-2013-1801): The httparty gem 0.9.0 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to…

- Severity: Unrated
- Published: Apr 9, 2013
- Affected: fixed in 0.10.0.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/rubygems/httparty
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
