Skip to main content
← RubyGems

httparty

3 known vulnerabilities (1 high, 1 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
3 · 1 high, 1 medium
Registry
RubyGems

Advisories 3

  • httparty Has Potential SSRF Vulnerability That Leads to API Key Leakage

    Affected: fixed in 0.24.0.

  • CVE-2024-22049Medium 5.3

    httparty Multipart/Form-Data Request Tampering Vulnerability

    Affected: through 0.20.0; fixed in 0.21.0.

  • The httparty gem 0.9.0 and earlier for Ruby does not properly restrict casts of string values, which might allow remote attackers to…

    Affected: fixed in 0.10.0.