# gollum (RubyGems) vulnerabilities

3 known vulnerabilities, with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://rubygems.org/gems/gollum

## Advisories (3)

### [CVE-2020-35305](https://cve.now/CVE-2020-35305): Cross site scripting (XSS) in gollum 5.0 to 5.1.2 via the filename parameter to the 'New Page' dialog.

- Severity: Unrated
- Published: Jul 15, 2022
- Affected: from 5.0, fixed in 5.1.2.

### [CVE-2014-9489](https://cve.now/CVE-2014-9489): The gollum-grit\_adapter Ruby gem dependency in gollum before 3.1.1 and the gollum-lib gem dependency in gollum-lib before 4.0.1 when the…

- Severity: Unrated
- Published: Oct 17, 2017
- Affected: fixed in 3.1.1.

### [CVE-2015-7314](https://cve.now/CVE-2015-7314): The Precious module in gollum before 4.0.1 allows remote attackers to read arbitrary files by leveraging the lack of a certain…

- Severity: Unrated
- Published: Oct 3, 2015
- Affected: fixed in 4.0.1.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/rubygems/gollum
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
