# fluentd (RubyGems) vulnerabilities

7 known vulnerabilities (1 critical, 3 high, 1 medium, 1 low), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://rubygems.org/gems/fluentd

## Advisories (7)

### [CVE-2026-44161](https://cve.now/CVE-2026-44161): Fluentd: Server-Side Request Forgery (SSRF) via Placeholder Expansion in \`out\_http\`

- Severity: High 7.2
- Published: Jul 8, 2026
- Affected: fixed in 1.19.3.

### [CVE-2026-44160](https://cve.now/CVE-2026-44160): Fluentd: Denial of Service (DoS) via Gzip Decompression Bomb in \`in\_http\` and \`in\_forward\`

- Severity: High 7.5
- Published: Jul 8, 2026
- Affected: fixed in 1.19.3.

### [CVE-2026-44025](https://cve.now/CVE-2026-44025): Fluentd: Exposure of Sensitive Information via Monitor Agent API

- Severity: High 7.5
- Published: Jul 8, 2026
- Affected: fixed in 1.19.3.

### [CVE-2026-44024](https://cve.now/CVE-2026-44024): Fluentd: Remote Code Execution (RCE) via Arbitrary File Write in \`${tag}\` Placeholder

- Severity: Critical 9.8
- Published: Jul 8, 2026
- Affected: fixed in 1.19.3.

### [CVE-2022-39379](https://cve.now/CVE-2022-39379): Fluentd vulnerable to remote code execution due to insecure deserialization (in non-default configuration)

- Severity: Low 3.1
- Published: Nov 2, 2022
- Affected: from 1.13.2, fixed in 1.15.3.

### [CVE-2021-41186](https://cve.now/CVE-2021-41186): ReDoS vulnerability in parser\_apache2

- Severity: Medium 5.9
- Published: Oct 29, 2021
- Affected: from 0.14.14, fixed in 1.14.2.

### [CVE-2017-10906](https://cve.now/CVE-2017-10906): Escape sequence injection vulnerability in Fluentd versions 0.12.29 through 0.12.40 may allow an attacker to change the terminal UI or…

- Severity: Unrated
- Published: Dec 8, 2017
- Affected: from 0.12.29, fixed in 0.12.41.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/rubygems/fluentd
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
