Skip to main content
← RubyGems

fluentd

7 known vulnerabilities (1 critical, 3 high, 1 medium, 1 low), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
7 · 1 critical, 3 high, 1 medium, 1 low
Registry
RubyGems

Advisories 7

  • Fluentd: Server-Side Request Forgery (SSRF) via Placeholder Expansion in `out_http`

    Affected: fixed in 1.19.3.

  • Fluentd: Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward`

    Affected: fixed in 1.19.3.

  • Fluentd: Exposure of Sensitive Information via Monitor Agent API

    Affected: fixed in 1.19.3.

  • CVE-2026-44024Critical 9.8

    Fluentd: Remote Code Execution (RCE) via Arbitrary File Write in `${tag}` Placeholder

    Affected: fixed in 1.19.3.

  • Fluentd vulnerable to remote code execution due to insecure deserialization (in non-default configuration)

    Affected: from 1.13.2, fixed in 1.15.3.

  • CVE-2021-41186Medium 5.9

    ReDoS vulnerability in parser_apache2

    Affected: from 0.14.14, fixed in 1.14.2.

  • Escape sequence injection vulnerability in Fluentd versions 0.12.29 through 0.12.40 may allow an attacker to change the terminal UI or…

    Affected: from 0.12.29, fixed in 0.12.41.