# ember-source (RubyGems) vulnerabilities

6 known vulnerabilities, with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://rubygems.org/gems/ember-source

## Advisories (6)

### [CVE-2013-4170](https://cve.now/CVE-2013-4170): In general, Ember.js escapes or strips any user-supplied content before inserting it in strings that will be sent to innerHTML.

- Severity: Unrated
- Published: Jun 30, 2022
- Affected: fixed in 1.0.0.rc1.1; from 1.0.0.rc2.0, fixed in 1.0.0.rc2.1; from 1.0.0.rc3.0, fixed in 1.0.0.rc3.1; from 1.0.0.rc4.0, fixed in 1.0.0.rc4.1; from 1.0.0.rc5.0, fixed in 1.0.0.rc5.1; from 1.0.0.rc6.0, fixed in 1.0.0.rc6.1.

### [CVE-2014-0014](https://cve.now/CVE-2014-0014): Ember.js 1.0.x before 1.0.1, 1.1.x before 1.1.3, 1.2.x before 1.2.1, 1.3.x before 1.3.1, and 1.4.x before 1.4.0-beta.2 allows remote…

- Severity: Unrated
- Published: Feb 15, 2018
- Affected: from 1.0.0.pre4.0, fixed in 1.0.1; from 1.1.0, fixed in 1.1.3; from 1.2.0.beta.1, fixed in 1.2.1; from 1.3.0.beta.1, fixed in 1.3.1; from 1.4.0-beta.1, fixed in 1.4.0-beta.2.

### [CVE-2014-0013](https://cve.now/CVE-2014-0013): Ember.js 1.0.x before 1.0.1, 1.1.x before 1.1.3, 1.2.x before 1.2.1, 1.3.x before 1.3.1, and 1.4.x before 1.4.0-beta.2 allows remote…

- Severity: Unrated
- Published: Feb 15, 2018
- Affected: from 1.0.0.pre4.0, fixed in 1.0.1; from 1.1.0, fixed in 1.1.3; from 1.2.0.beta.1, fixed in 1.2.1; from 1.3.0.beta.1, fixed in 1.3.1; from 1.4.0-beta.1, fixed in 1.4.0-beta.2.

### [CVE-2015-1866](https://cve.now/CVE-2015-1866): Cross-site scripting (XSS) vulnerability in Ember.js 1.10.x before 1.10.1 and 1.11.x before 1.11.2.

- Severity: Unrated
- Published: Sep 20, 2017
- Affected: from 1.10.0, fixed in 1.10.1; from 1.11.0, fixed in 1.11.2.

### [CVE-2015-7565](https://cve.now/CVE-2015-7565): Cross-site scripting (XSS) vulnerability in Ember.js 1.8.x through 1.10.x, 1.11.x before 1.11.4, 1.12.x before 1.12.2, 1.13.x before…

- Severity: Unrated
- Published: Apr 13, 2017
- Affected: from 1.8.0, fixed in 1.11.4; from 1.12.0, fixed in 1.12.2; from 1.13.0, fixed in 1.13.12; from 2.0.0, fixed in 2.0.3; from 2.1.0, fixed in 2.1.2; from 2.2.0, fixed in 2.2.1.

### [CVE-2014-0046](https://cve.now/CVE-2014-0046): Cross-site scripting (XSS) vulnerability in the link-to helper in Ember.js 1.2.x before 1.2.2, 1.3.x before 1.3.2, and 1.4.x before…

- Severity: Unrated
- Published: Feb 27, 2014
- Affected: from 1.2.0, fixed in 1.2.2; from 1.3.0, fixed in 1.3.2; from 1.4.0.beta.1, fixed in 1.4.0.beta.6.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/rubygems/ember-source
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
