Skip to main content
← RubyGems

dragonfly

4 known vulnerabilities, with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
4
Registry
RubyGems

Advisories 4

  • An argument injection vulnerability in Dragonfly Ruby Gem v1.3.0 allows attackers to read and write arbitrary files when the verify_url…

    Affected: fixed in 1.4.0.

  • An argument injection vulnerability in the Dragonfly gem before 1.4.0 for Ruby allows remote attackers to read and write to arbitrary…

    Affected: fixed in 1.4.0.

  • The Dragonfly gem 0.7 before 0.8.6 and 0.9.x before 0.9.13 for Ruby, when used with Ruby on Rails, allows remote attackers to execute…

    Affected: from 0.7, fixed in 0.8.6; from 0.9, fixed in 0.9.13.

  • lib/dragonfly/imagemagickutils.rb in the fog-dragonfly gem 0.8.2 for Ruby allows remote attackers to execute arbitrary commands via…

    Affected: fixed in 1.0.0.