# devise-two-factor (RubyGems) vulnerabilities

3 known vulnerabilities (1 medium), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://rubygems.org/gems/devise-two-factor

## Advisories (3)

### [CVE-2024-8796](https://cve.now/CVE-2024-8796): Insufficient Default OTP Shared Secret Length

- Severity: Medium 6.0
- Published: Sep 17, 2024
- Affected: from 4.0.0, fixed in 6.0.0; versions 1.0.0.

### [CVE-2021-43177](https://cve.now/CVE-2021-43177): As a result of an incomplete fix for CVE-2015-7225, in versions of devise-two-factor prior to 4.0.2 it is possible to reuse a…

- Severity: Unrated
- Published: Apr 11, 2022
- Affected: fixed in 4.0.2.

### [CVE-2015-7225](https://cve.now/CVE-2015-7225): Tinfoil Devise-two-factor before 2.0.0 does not strictly follow section 5.2 of RFC 6238 and does not "burn" a successfully validated…

- Severity: Unrated
- Published: Sep 6, 2017
- Affected: fixed in 2.0.0.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/rubygems/devise-two-factor
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
