Skip to main content
← RubyGems

devise-two-factor

3 known vulnerabilities (1 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
3 · 1 medium
Registry
RubyGems

Advisories 3

  • CVE-2024-8796Medium 6.0

    Insufficient Default OTP Shared Secret Length

    Affected: from 4.0.0, fixed in 6.0.0; versions 1.0.0.

  • As a result of an incomplete fix for CVE-2015-7225, in versions of devise-two-factor prior to 4.0.2 it is possible to reuse a…

    Affected: fixed in 4.0.2.

  • Tinfoil Devise-two-factor before 2.0.0 does not strictly follow section 5.2 of RFC 6238 and does not "burn" a successfully validated…

    Affected: fixed in 2.0.0.