# avo (RubyGems) vulnerabilities

8 known vulnerabilities (1 critical, 4 high, 3 medium), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://rubygems.org/gems/avo

## Advisories (8)

### [CVE-2026-53769](https://cve.now/CVE-2026-53769): Avo: Direct attachment upload endpoint lacks upload authorization and bypasses field-level upload policy

- Severity: Medium 6.5
- Published: Sep 4, 2026
- Affected: from 2.28.0, fixed in 3.32.0.

### [CVE-2026-55518](https://cve.now/CVE-2026-55518): Avo: Missing Authorization in Avo Association Attach Endpoint Allows Unauthorized Relationship Manipulation and Privilege Escalation

- Severity: Critical 9.6
- Published: Jul 17, 2026
- Affected: fixed in 3.32.1; from 4.0.0.beta.1, fixed in 4.0.0.beta.51.

### [CVE-2026-42205](https://cve.now/CVE-2026-42205): Avo: Broken Access Control: Unauthorized Execution of Arbitrary Action Classes Across Resources

- Severity: High 8.8
- Published: May 8, 2026
- Affected: fixed in 3.31.2.

### [CVE-2026-33209](https://cve.now/CVE-2026-33209): Avo has a XSS vulnerability on \`return\_to\` param

- Severity: Medium 5.3
- Published: Mar 20, 2026
- Affected: fixed in 3.30.3.

### [CVE-2024-22411](https://cve.now/CVE-2024-22411): Cross site scripting in Action messages on Avo

- Severity: Medium 6.5
- Published: Jan 16, 2024
- Affected: from 3.0.0.beta1, fixed in 3.3.0; fixed in 2.47.0.

### [CVE-2024-22191](https://cve.now/CVE-2024-22191): Stored cross-site scripting (XSS) in \`key\_value\` field in Avo

- Severity: High 7.3
- Published: Jan 16, 2024
- Affected: from 3.0.0.beta1, fixed in 3.2.4; fixed in 2.47.0.

### [CVE-2023-34102](https://cve.now/CVE-2023-34102): Possible unsafe reflection / partial denial of service in avo

- Severity: High 8.3
- Published: Jun 5, 2023
- Affected: fixed in 2.33.3; from 3.0.0.pre1, through 3.0.0.pre12.

### [CVE-2023-34103](https://cve.now/CVE-2023-34103): Stored XSS (Cross Site Scripting) in html content based fields of avo

- Severity: High 7.3
- Published: Jun 5, 2023
- Affected: fixed in 2.33.3; from 3.0.0.pre1, through 3.0.0.pre12.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/rubygems/avo
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
