# wolfssl (PyPI) vulnerabilities

1 known vulnerability (1 critical), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: 5.9.2.post0 (Jul 16, 2026): no advisory affects it
- Newest unaffected release: 5.9.2.post0 (Jul 16, 2026), the latest release
- Weekly downloads: 628
- Dependents: 0
- Releases: 19 since 0.1.0 (May 11, 2017)
- Registry: https://pypi.org/project/wolfssl/
- Releases read: Nov 8, 2026

## Version timeline

Affected versions per advisory, in version order:

- CVE-2025-15346: 0.1.0 to 5.8.2.post0 (5.8.4.post0 is outside it)

## Advisories (1)

### [CVE-2025-15346](https://cve.now/CVE-2025-15346): wolfSSL Python library \`CERT\_REQUIRED\` mode fails to enforce client certificate requirement

- Severity: Critical 9.3
- Published: Jan 7, 2026
- Affected: from 5.3.0, through 5.8.2; fixed in 5.8.4.post0.
- Fixed in 5.8.4.post0 (released Dec 30, 2025, 8 days before disclosure).
- The latest release, 5.9.2.post0, is not affected.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/pypi/wolfssl
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
