Skip to main content
← PyPI

vtk

4 known vulnerabilities (1 critical, 2 high), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
4 · 1 critical, 2 high
Registry
PyPI

Advisories 4

  • CVE-2025-57108Critical 9.8

    Kitware VTK (Visualization Toolkit) through 9.5.0 contains a heap use-after-free vulnerability in vtkGLTFDocumentLoader.

    Affected: fixed in 9.5.1.

  • Kitware VTK (Visualization Toolkit) through 9.5.0 contains a heap buffer overflow vulnerability in vtkGLTFDocumentLoader.

    Affected: fixed in 9.5.1.

  • Kitware VTK (Visualization Toolkit) up to 9.5.0 is vulnerable to Buffer Overflow in vtkGLTFDocumentLoader.

    Affected: fixed in 9.5.1.

  • There is a NULL pointer dereference vulnerability in VTK before 9.2.5, and it lies in IO/Infovis/vtkXMLTreeReader.cxx.

    Affected: fixed in 9.0.1.