Skip to main content
← PyPI

swift

14 known vulnerabilities (1 high, 2 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
14 · 1 high, 2 medium
Weekly downloads
1,301
Dependents
1
Registry
PyPI

Advisories 14

  • CVE-2026-50221Medium 5.3

    In OpenStack Swift before 2.37.2, proxy-server does not strip internal update headers (X-Container-Host, X-Container-Device…

    Affected: fixed in 2.37.2; fixed in 2.37.2.

  • In OpenStack Swift before 2.36.2 and 2.37.2, s3api middleware enters an infinite loop when processing a truncated aws-chunked PUT request…

    Affected: from 2.36.0, through 2.36.1; from 2.37.0, through 2.37.1; from 2.36.0, through 2.36.1; from 2.37.0, through 2.37.1.

  • CVE-2022-47950Medium 6.5

    An issue was discovered in OpenStack Swift before 2.28.1, 2.29.x before 2.29.2, and 2.30.0.

    Affected: fixed in 2.28.1; from 2.29.0, fixed in 2.29.2; from 2.30.0, fixed in 2.30.1; fixed in 2.28.1; from 2.29.0, fixed in 2.29.2; from 2.30.0, fixed in 2.30.1.

  • In OpenStack Swift through 2.10.1, 2.11.0 through 2.13.0, and 2.14.0, the proxy-server logs full tempurl paths, potentially leaking…

    Affected: fixed in 2.15.2.

  • OpenStack Object Storage (Swift) before 2.3.1 (Kilo), 2.4.x, and 2.5.x before 2.5.1 (Liberty) do not properly close server connections…

    Affected: fixed in 2.3.1; from 2.4.0, fixed in 2.5.1; fixed in 2.3.1; from 2.4.0, fixed in 2.5.1.

  • OpenStack Object Storage (Swift) before 2.4.0 does not properly close client connections, which allows remote attackers to cause a denial…

    Affected: fixed in 2.4.0.

  • OpenStack Object Storage (Swift) before 2.4.0 allows attackers to obtain sensitive information via a PUT tempurl and a DLO object manifest…

    Affected: fixed in 2.4.0.

  • OpenStack Object Storage (Swift) before 2.3.0, when allow_version is configured, allows remote authenticated users to delete the latest…

    Affected: fixed in 2.3.0.

  • OpenStack Object Storage (Swift) before 2.2.0 allows remote authenticated users to bypass the max_meta_count and other metadata…

    Affected: fixed in 2.2.0.

  • Cross-site scripting (XSS) vulnerability in OpenStack Swift 1.11.0 through 1.13.1 allows remote attackers to inject arbitrary web script…

    Affected: from 1.11.0, fixed in 2.0.0.

  • The TempURL middleware in OpenStack Object Storage (Swift) 1.4.6 through 1.8.0, 1.9.0 through 1.10.0, and 1.11.0 allows remote attackers…

    Affected: from 1.4.6, through 1.8.0; from 1.9.0, through 1.10.0; from 1.11.0, fixed in 1.12.0; from 1.4.6, fixed in 1.12.0.

  • OpenStack Swift before 1.9.1 in Folsom, Grizzly, and Havana allows authenticated users to cause a denial of service ("superfluous"…

    Affected: fixed in 1.9.1.

  • XML injection vulnerability in account/utils.py in OpenStack Swift Folsom, Grizzly, and Havana allows attackers to trigger invalid or…

    Affected: fixed in 1.9.0.

  • OpenStack Object Storage (swift) before 1.7.0 uses the loads function in the pickle Python module unsafely when storing and loading…

    Affected: fixed in 1.7.0.