Skip to main content
← PyPI

supervisor

2 known vulnerabilities, with the versions each affects and the releases that fix them.

Latest release
4.3.0 (Aug 23, 2025): no advisory with comparable ranges affects it; 2 advisories (CVE-2019-12105, CVE-2017-11610) can't be checked against versions
Newest unaffected release
4.3.0 (Aug 23, 2025), the latest release, not counting 2 advisories without comparable ranges
Advisories
2
Weekly downloads
2.3M
Dependents
190
Releases
40 since 3.0.0 (Jul 31, 2013)
Registry
PyPI
Releases read
Nov 8, 2026

Version timeline

  • CVE-2019-12105
    Its ranges can't be placed on these versions
    Its ranges can't be placed on these versions
  • CVE-2017-11610
    Its ranges can't be placed on these versions
    Its ranges can't be placed on these versions
Every release cve.now has on record, lowest version on the left; each bar is a run of versions an advisory affects.

Advisories 2

  • In Supervisor through 4.0.2, an unauthenticated user can read log files or restart a service.

    Affected: fixed in 4.0.3.

  • The XML-RPC server in supervisor before 3.0.1, 3.1.x before 3.1.4, 3.2.x before 3.2.4, and 3.3.x before 3.3.3 allows remote authenticated…

    Affected: fixed in 3.0.1; from 3.1.0, fixed in 3.1.4; from 3.2.0, fixed in 3.2.4; from 3.3.0, fixed in 3.3.3; fixed in 3.0.1; from 3.1, fixed in 3.1.4; from 3.2, fixed in 3.2.4; from 3.3, fixed in 3.3.3.