Skip to main content
← PyPI

sickrage

3 known vulnerabilities (2 medium), with the versions each affects and the releases that fix them.

Latest release
10.0.71 (Jun 6, 2023): affected by CVE-2018-9160
Newest unaffected release
Every release is affected by at least one advisory
Advisories
3 · 2 medium
Weekly downloads
482
Dependents
0
Releases
500+ since 9.4.148 (Jul 20, 2019)
Registry
PyPI
Releases read
Nov 8, 2026

Version timeline

  • CVE-2021-25925
    Affects 9.4.148.dev1 to 10.0.11 (10.0.12.dev1 is outside it)
  • CVE-2021-25926
    Affects 9.4.148.dev1 to 10.0.11 (10.0.12.dev1 is outside it)
  • CVE-2018-9160
    Affects 9.4.148.dev1 to 10.0.71 (through the newest release)
Every release cve.now has on record, lowest version on the left; each bar is a run of versions an advisory affects. Older releases aren't stored, so the earliest spans may start sooner.

Advisories 3

  • CVE-2021-25925Medium 5.4

    in SiCKRAGE, versions 4.2.0 to 10.0.11.dev1 are vulnerable to Stored Cross-Site-Scripting (XSS) due to user input not being validated…

    Affected: from 4.2.0, fixed in 10.0.12.dev1; from 4.2.0, fixed in 10.0.11.dev2.

    Fixed in 10.0.12.dev1 (released Mar 14, 2021, 29 days before disclosure).

    The latest release, 10.0.71, is not affected.

  • CVE-2021-25926Medium 6.1

    In SiCKRAGE, versions 9.3.54.dev1 to 10.0.11.dev1 are vulnerable to Reflected Cross-Site-Scripting (XSS) due to user input not being…

    Affected: from 9.3.55, fixed in 10.0.12.dev1; from 9.3.54, fixed in 10.0.11.dev2.

    Fixed in 10.0.12.dev1 (released Mar 14, 2021, 29 days before disclosure).

    The latest release, 10.0.71, is not affected.

  • SickRage before v2018.03.09-1 includes cleartext credentials in HTTP responses.

    Affected: fixed in 2018.03.09-1; fixed in 9.3.2.

    No fix released. The advisory names 2018.03.09-1 as the fix, which the registry doesn't have yet. The latest release, 10.0.71, is still affected.