Skip to main content
← PyPI

scikit-learn

3 known vulnerabilities (1 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
3 · 1 medium
Registry
PyPI

Advisories 3

  • CVE-2024-5206Medium 4.7

    Sensitive Data Leakage in sklearn.feature_extraction.text.TfidfVectorizer in scikit-learn/scikit-learn

    Affected: fixed in 1.5.0; fixed in 1.5.0.

  • svm_predict_values in svm.cpp in Libsvm v324, as used in scikit-learn 0.23.2 and other products, allows attackers to cause a denial of…

    Affected: from 0.23.2, fixed in 1.0.1; fixed in 0.24.dev0.

  • scikit-learn (aka sklearn) through 0.23.0 can unserialize and execute commands from an untrusted file that is passed to the joblib.load()…

    Affected: through 0.23.0; fixed in 0.23.1.