# requests (PyPI) vulnerabilities

8 known vulnerabilities (4 medium), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Weekly downloads: 353.4M
- Dependents: 189.2K
- Registry: https://pypi.org/project/requests/

## Advisories (8)

### [CVE-2026-25645](https://cve.now/CVE-2026-25645): Requests has Insecure Temp File Reuse in its extract\_zipped\_paths() utility function

- Severity: Medium 4.4
- Published: Mar 25, 2026
- Affected: fixed in 2.33.0.

### [CVE-2024-47081](https://cve.now/CVE-2024-47081): Requests vulnerable to .netrc credentials leak via malicious URLs

- Severity: Medium 5.3
- Published: Jun 9, 2025
- Affected: fixed in 2.32.4.

### [CVE-2024-35195](https://cve.now/CVE-2024-35195): Requests \`Session\` object does not verify requests after making first request with verify=False

- Severity: Medium 5.6
- Published: May 20, 2024
- Affected: fixed in 2.32.0.

### [CVE-2023-32681](https://cve.now/CVE-2023-32681): Unintended leak of Proxy-Authorization header in requests

- Severity: Medium 6.1
- Published: May 26, 2023
- Affected: from 2.3.0, fixed in 2.31.0.

### [CVE-2018-18074](https://cve.now/CVE-2018-18074): The Requests package before 2.20.0 for Python sends an HTTP Authorization header to an http URI upon receiving a same-hostname…

- Severity: Unrated
- Published: Oct 9, 2018
- Affected: fixed in 2.20.0.

### [CVE-2015-2296](https://cve.now/CVE-2015-2296): The resolve\_redirects function in sessions.py in requests 2.1.0 through 2.5.3 allows remote attackers to conduct session fixation attacks…

- Severity: Unrated
- Published: Mar 18, 2015
- Affected: from 2.1.0, fixed in 2.6.0; from 2.1.0, fixed in 2.6.0.

### [CVE-2014-1830](https://cve.now/CVE-2014-1830): Requests (aka python-requests) before 2.3.0 allows remote servers to obtain sensitive information by reading the Proxy-Authorization…

- Severity: Unrated
- Published: Oct 15, 2014
- Affected: fixed in 2.3.0.

### [CVE-2014-1829](https://cve.now/CVE-2014-1829): Requests (aka python-requests) before 2.3.0 allows remote servers to obtain a netrc password by reading the Authorization header in a…

- Severity: Unrated
- Published: Oct 15, 2014
- Affected: fixed in 2.3.0.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/pypi/requests
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
