# pyyaml (PyPI) vulnerabilities

4 known vulnerabilities (1 critical), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://pypi.org/project/pyyaml/

## Advisories (4)

### [CVE-2020-14343](https://cve.now/CVE-2020-14343): A vulnerability was discovered in the PyYAML library in versions before 5.4, where it is susceptible to arbitrary code execution when it…

- Severity: Unrated
- Published: Feb 9, 2021
- Affected: fixed in 5.4.

### [CVE-2020-1747](https://cve.now/CVE-2020-1747): A vulnerability was discovered in the PyYAML library in versions before 5.3.1, where it is susceptible to arbitrary code execution when it…

- Severity: Critical 9.8
- Published: Mar 24, 2020
- Affected: from 5.1, fixed in 5.3.1; from 5.1b7, fixed in 5.3.1.

### [CVE-2019-20477](https://cve.now/CVE-2019-20477): PyYAML 5.1 through 5.1.2 has insufficient restrictions on the load and load\_all functions because of a class deserialization issue, e.g…

- Severity: Unrated
- Published: Feb 19, 2020
- Affected: from 5.1, fixed in 5.2b1; from 5.1, fixed in 5.2.

### [CVE-2017-18342](https://cve.now/CVE-2017-18342): In PyYAML before 5.1, the yaml.load() API could execute arbitrary code if used with untrusted data.

- Severity: Unrated
- Published: Jun 27, 2018
- Affected: fixed in 5.1.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/pypi/pyyaml
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
