Skip to main content
← PyPI

pyyaml

4 known vulnerabilities (1 critical), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
4 · 1 critical
Registry
PyPI

Advisories 4

  • A vulnerability was discovered in the PyYAML library in versions before 5.4, where it is susceptible to arbitrary code execution when it…

    Affected: fixed in 5.4.

  • CVE-2020-1747Critical 9.8

    A vulnerability was discovered in the PyYAML library in versions before 5.3.1, where it is susceptible to arbitrary code execution when it…

    Affected: from 5.1, fixed in 5.3.1; from 5.1b7, fixed in 5.3.1.

  • PyYAML 5.1 through 5.1.2 has insufficient restrictions on the load and load_all functions because of a class deserialization issue, e.g…

    Affected: from 5.1, fixed in 5.2b1; from 5.1, fixed in 5.2.

  • In PyYAML before 5.1, the yaml.load() API could execute arbitrary code if used with untrusted data.

    Affected: fixed in 5.1.