Skip to main content
← PyPI

python-gnupg

5 known vulnerabilities, with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
5
Registry
PyPI

Advisories 5

  • python-gnupg 0.4.3 allows context-dependent attackers to trick gnupg to decrypt other ciphertext than intended.

    Affected: fixed in 0.4.4.

  • python-gnupg 0.3.5 and 0.3.6 allows context-dependent attackers to have an unspecified impact via vectors related to "option injection…

    Affected: from 0.3.5, fixed in 0.3.7.

  • The shell_quote function in python-gnupg 0.3.5 does not properly escape characters, which allows context-dependent attackers to execute…

    Affected: fixed in 0.3.6; from 0.3.5, fixed in 0.3.6.

  • The shell_quote function in python-gnupg 0.3.5 does not properly quote strings, which allows context-dependent attackers to execute…

    Affected: from 0.3.5, fixed in 0.3.6.

  • python-gnupg before 0.3.5 allows context-dependent attackers to execute arbitrary commands via shell metacharacters in unspecified vectors.

    Affected: fixed in 0.3.5; fixed in 0.3.7.