Skip to main content
← PyPI

pygments

5 known vulnerabilities (1 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
5 · 1 medium
Registry
PyPI

Advisories 5

  • CVE-2026-4539Medium 4.8

    pygments archetype.py AdlLexer redos

    Affected: fixed in 2.20.0.

  • A ReDoS issue was discovered in pygments/lexers/smithy.py in pygments through 2.15.0 via SmithyLexer.

    Affected: fixed in 2.15.1; fixed in 2.15.0.

  • An infinite loop in SMLLexer in Pygments versions 1.5 to 2.7.3 may lead to denial of service when performing syntax highlighting of a…

    Affected: from 1.5, fixed in 2.7.4.

  • In pygments 1.1+, fixed in 2.7.4, the lexers used to parse programming languages rely heavily on regular expressions.

    Affected: from 1.1, fixed in 2.7.4.

  • The FontManager._get_nix_font_path function in formatters/img.py in Pygments 1.2.2 through 2.0.2 allows remote attackers to execute…

    Affected: from 1.2.2, fixed in 2.1.