# pulsar-client (PyPI) vulnerabilities

1 known vulnerability (1 high), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://pypi.org/project/pulsar-client/

## Advisories (1)

### [CVE-2022-33684](https://cve.now/CVE-2022-33684): Apache Pulsar C++/Python OAuth Clients prior to 3.0.0 were vulnerable to an MITM attack due to Disabled Certificate Validation

- Severity: High 8.1
- Published: Nov 4, 2022
- Affected: fixed in 2.7.5; from 2.8.0, fixed in 2.8.4; from 2.9.0, fixed in 2.9.3; from 2.10.0, fixed in 2.10.2; fixed in 2.7.5; from 2.8.0, fixed in 2.8.4; from 2.9.0, fixed in 2.9.3; from 2.10.0, fixed in 2.10.2.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/pypi/pulsar-client
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
