Skip to main content
← PyPI

pandasai

4 known vulnerabilities (2 critical), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
4 · 2 critical
Registry
PyPI

Advisories 4

  • CVE-2024-12366Critical 9.8

    CVE-2024-12366

    Affected: through 2.4.2.

  • CVE-2024-23752Critical 9.8

    GenerateSDFPipeline in synthetic_dataframe in PandasAI (aka pandas-ai) through 1.5.17 allows attackers to trigger the generation of…

    Affected: through 1.5.17.

  • An issue in Gaberiele Venturi pandasai v.0.8.0 and before allows a remote attacker to execute arbitrary code via a crafted request to the…

    Affected: fixed in 0.8.1.

  • An issue in pandas-ai v.0.9.1 and before allows a remote attacker to execute arbitrary code via the _is_jailbreak function.

    Affected: through 0.8.1.