Skip to main content
← PyPI

paddlepaddle

32 known vulnerabilities (11 critical, 7 high, 14 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
32 · 11 critical, 7 high, 14 medium
Registry
PyPI

Advisories 32

  • confirmed

    Affected: through 2.6.0.

  • CVE-2024-0818Critical 9.1

    Arbitrary File Overwrite Via Path Traversal in paddlepaddle/paddle before 2.6

    Affected: through 2.6.0.

  • CVE-2024-0917Critical 9.4

    remote code execution in paddlepaddle/paddle 2.6.0

    Affected: through 2.6.0.

  • CVE-2024-0815Critical 9.3

    Command injection in paddle.utils.download._wget_download (bypass filter) in paddlepaddle/paddle 2.6.0

    Affected: fixed in 3.0.0-beta0; through 2.6.0.

  • CVE-2024-0817Critical 9.3

    Command injection in IrGraph.draw in paddlepaddle/paddle 2.6.0

    Affected: fixed in 3.0.0-beta0; through 2.6.0.

  • CVE-2024-0521Critical 9.3

    Code Injection in paddlepaddle/paddle

    Affected: fixed in 2.6.0.

  • CVE-2023-52314Critical 9.6

    Command injection in convert_shape_compare

    Affected: fixed in 2.6.0; fixed in 2.6.0.

  • CVE-2023-52313Medium 4.7

    FPE in paddle.argmin and paddle.argmax

    Affected: fixed in 2.6.0; fixed in 2.6.0.

  • CVE-2023-52312Medium 4.7

    Null pointer dereference in paddle.crop

    Affected: fixed in 2.6.1; fixed in 2.6.0.

  • CVE-2023-52311Critical 9.6

    Command injection in _wget_download

    Affected: fixed in 2.6.0; fixed in 2.6.0.

  • CVE-2023-52310Critical 9.6

    Command injection in get_online_pass_interval

    Affected: fixed in 2.6.0; fixed in 2.6.0.

  • Heap buffer overflow in paddle.repeat_interleave

    Affected: fixed in 2.6.0; fixed in 2.6.0.

  • CVE-2023-52308Medium 4.7

    FPE in paddle.amin

    Affected: fixed in 2.6.0; fixed in 2.6.0.

  • Stack overflow in paddle.linalg.lu_unpack

    Affected: fixed in 2.6.0; fixed in 2.6.0.

  • CVE-2023-52306Medium 4.7

    FPE in paddle.lerp

    Affected: fixed in 2.6.0; fixed in 2.6.0.

Show all 32 advisoriesShow fewer advisories
  • CVE-2023-52305Medium 4.7

    FPE in paddle.topk

    Affected: fixed in 2.6.0; fixed in 2.6.0.

  • Stack overflow in paddle.searchsorted

    Affected: fixed in 2.6.0; fixed in 2.6.0.

  • CVE-2023-52303Medium 4.7

    Segfault in paddle.put_along_axis

    Affected: fixed in 2.6.0; fixed in 2.6.0.

  • CVE-2023-52302Medium 4.7

    Segfault in paddle.nextafter

    Affected: fixed in 2.6.0; fixed in 2.6.0.

  • CVE-2023-38678Medium 4.7

    Segfault in paddle.mode

    Affected: fixed in 2.6.0; fixed in 2.6.0.

  • CVE-2023-38677Medium 4.7

    FPE in paddle.linalg.eig

    Affected: fixed in 2.6.0; fixed in 2.6.0.

  • CVE-2023-38676Medium 4.7

    Segfault in paddle.dot

    Affected: fixed in 2.6.0; fixed in 2.6.0.

  • CVE-2023-38675Medium 4.7

    FPE in paddle.linalg.matrix_rank

    Affected: fixed in 2.6.0; fixed in 2.6.0.

  • CVE-2023-38674Medium 4.7

    FPE in paddle.nanmedian

    Affected: fixed in 2.6.0; fixed in 2.6.0.

  • CVE-2023-38673Critical 9.6

    Command injection in fs.py

    Affected: fixed in 2.5.0; fixed in 2.5.0.

  • CVE-2023-38672Medium 4.7

    FPE in paddle.linalg.matrix_power

    Affected: fixed in 2.5.0; fixed in 2.5.0.

  • Heap buffer overflow in paddle.trace

    Affected: fixed in 2.5.0; fixed in 2.5.0.

  • CVE-2023-38670Medium 4.7

    Null pointer dereference in paddle.flip

    Affected: fixed in 2.5.0; fixed in 2.5.0.

  • Use after free in paddle.diagonal in PaddlePaddle before 2.5.0.

    Affected: fixed in 2.5.0; fixed in 2.5.0.

  • CVE-2022-46742Critical 10.0

    Code injection in paddle.audio.functional.get_window in PaddlePaddle 2.4.0-rc0 allows arbitrary code execution.

    Affected: fixed in 2.4.0; fixed in 2.4.0.

  • Out-of-bounds read in gather_tree in PaddlePaddle before 2.4.

    Affected: fixed in 2.4.

  • CVE-2022-45908Critical 9.8

    In PaddlePaddle before 2.4, paddle.audio.functional.get_window is vulnerable to code injection because it calls eval on a user-supplied…

    Affected: fixed in 2.4.