# oslo-middleware (PyPI) vulnerabilities

1 known vulnerability (1 medium), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://pypi.org/project/oslo-middleware/

## Advisories (1)

### [CVE-2017-2592](https://cve.now/CVE-2017-2592): python-oslo-middleware before versions 3.8.1, 3.19.1, 3.23.1 is vulnerable to an information disclosure.

- Severity: Medium 5.9
- Published: May 8, 2018
- Affected: from 3.9.0, fixed in 3.19.1; fixed in 3.8.1; from 3.20.0, fixed in 3.23.1; from 3.9.0, fixed in 3.19.1; fixed in 3.8.1; from 3.20.0, fixed in 3.23.1.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/pypi/oslo-middleware
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
