# mako (PyPI) vulnerabilities

5 known vulnerabilities (2 high, 1 medium), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: 1.4.3 (Sep 22, 2026): no advisory affects it
- Newest unaffected release: 1.4.3 (Sep 22, 2026), the latest release
- Weekly downloads: 53M
- Dependents: 9,300
- Releases: 83 since 0.1.0 (Dec 31, 2006)
- Registry: https://pypi.org/project/mako/
- Releases read: Nov 8, 2026

## Version timeline

Affected versions per advisory, in version order:

- CVE-2026-102991: 0.1.0 to 1.4.1 (1.4.2 is outside it)
- CVE-2026-44307: 0.1.0 to 1.3.11 (1.3.12 is outside it)
- CVE-2026-41205: 0.1.0 to 1.3.10 (1.3.11 is outside it)
- CVE-2022-40023: 0.1.0 to 1.2.1 (1.2.2 is outside it)
- CVE-2010-2480: 0.1.0 to 0.3.3 (0.3.4 is outside it)

## Advisories (5)

### [CVE-2026-102991](https://cve.now/CVE-2026-102991): Mako: Path traversal via drive-letter URI on Windows in TemplateLookup

- Severity: Medium 6.5
- Published: Sep 30, 2026
- Affected: fixed in 1.4.2.
- Fixed in 1.4.2 (released Sep 22, 2026, 8 days before disclosure).
- The latest release, 1.4.3, is not affected.

### [CVE-2026-44307](https://cve.now/CVE-2026-44307): Mako: Path traversal via backslash URI on Windows in TemplateLookup

- Severity: High 8.7
- Published: May 12, 2026
- Affected: fixed in 1.3.12.
- Fixed in 1.3.12 (released Apr 28, 2026, 14 days before disclosure).
- The latest release, 1.4.3, is not affected.

### [CVE-2026-41205](https://cve.now/CVE-2026-41205): Mako: Path traversal via double-slash URI prefix in TemplateLookup

- Severity: High 7.7
- Published: Apr 23, 2026
- Affected: fixed in 1.3.11.
- Fixed in 1.3.11 (released Apr 14, 2026, 9 days before disclosure).
- The latest release, 1.4.3, is not affected.

### [CVE-2022-40023](https://cve.now/CVE-2022-40023): Sqlalchemy mako before 1.2.2 is vulnerable to Regular expression Denial of Service when using the Lexer class to parse.

- Severity: Unrated
- Published: Sep 7, 2022
- Affected: fixed in 1.2.2.
- Fixed in 1.2.2 (released Aug 29, 2022, 9 days before disclosure).
- The latest release, 1.4.3, is not affected.

### [CVE-2010-2480](https://cve.now/CVE-2010-2480): Mako before 0.3.4 relies on the cgi.escape function in the Python standard library for cross-site scripting (XSS) protection, which makes…

- Severity: Unrated
- Published: Jul 2, 2010
- Affected: fixed in 0.3.4.
- Fixed in 0.3.4 (released Jun 22, 2010, 10 days before disclosure).
- The latest release, 1.4.3, is not affected.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/pypi/mako
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
