Skip to main content
← PyPI

mage-ai

6 known vulnerabilities (1 high, 5 medium), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
6 · 1 high, 5 medium
Registry
PyPI

Advisories 6

  • CVE-2024-45190Medium 6.5

    Mage AI pipeline interaction request remote arbitrary file leak

    Affected: versions 0; through 0.9.73.

  • CVE-2024-45189Medium 6.5

    Mage AI git content request remote arbitrary file leak

    Affected: versions 0; through 0.9.73.

  • CVE-2024-45188Medium 6.5

    Mage AI file content request remote arbitrary file leak

    Affected: versions 0; through 0.9.73.

  • Mage AI allows deleted users to use the terminal server with admin access, leading to remote code execution

    Affected: versions 0; through 0.9.73.

  • CVE-2024-8072Medium 5.3

    Mage AI allows remote unauthenticated attackers to leak the terminal server command history of arbitrary users

    Affected: versions 0; through 0.9.73.

  • CVE-2023-31143Medium 5.9

    Mage terminal user authentication not working properly

    Affected: from 0.8.34, fixed in 0.8.72.