Skip to main content
← PyPI

langchain

22 known vulnerabilities (3 critical, 3 high, 5 medium, 1 low), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
22 · 3 critical, 3 high, 5 medium, 1 low
Weekly downloads
37.1M
Dependents
3,166
Registry
PyPI

Advisories 22

  • CVE-2026-55443Medium 5.1

    LangChain: Path traversal and sandbox escape in LangChain file-search middleware and loaders

    Affected: fixed in 1.3.9.

  • LangSmith Client SDK: Public prompt pull deserializes untrusted manifests without trust boundary warning

    Affected: fixed in 0.3.30.

  • CVE-2024-8309Medium 4.9

    SQL Injection in langchain-ai/langchain

    Affected: fixed in 0.2.0.

  • CVE-2024-5998Medium 5.2

    Deserialization of Untrusted Data in langchain-ai/langchain

    Affected: fixed in 0.2.9.

  • CVE-2024-2965Medium 4.2

    Denial-of-Service in LangChain SitemapLoader in langchain-ai/langchain

    Affected: fixed in 0.2.5; fixed in 0.2.5.

  • CVE-2024-3571Medium 6.5

    Path Traversal in langchain-ai/langchain

    Affected: fixed in 0.0.353.

  • LangChain through 0.1.10 allows ../ directory traversal by an actor who is able to control the final part of the path parameter in a…

    Affected: fixed in 0.0.339; fixed in 0.1.11.

  • Server-side Request Forgery In Recursive URL Loader

    Affected: fixed in 0.1.0.

  • In Langchain through 0.0.155, prompt injection allows an attacker to force the service to retrieve data from an arbitrary URL, essentially…

    Affected: fixed in 0.0.329.

  • LangChain before 0.0.317 allows SSRF via document_loaders/recursive_url_loader.py because crawling can proceed from an external server to…

    Affected: fixed in 0.0.317; fixed in 0.0.317.

  • An issue in LanChain-ai Langchain v.0.0.245 allows a remote attacker to execute arbitrary code via the evaluate function in the numexpr…

    Affected: fixed in 0.0.308; fixed in 0.0.308.

  • CVE-2023-36281Critical 9.8

    An issue in langchain v.0.0.171 allows a remote attacker to execute arbitrary code via a JSON file to load_prompt.

    Affected: fixed in 0.0.171; fixed in 0.0.312.

  • An issue in langchain langchain-ai v.0.0.232 and before allows a remote attacker to execute arbitrary code via a crafted script to the…

    Affected: fixed in 0.0.233; fixed in 0.0.325.

  • An issue in Harrison Chase langchain v.0.0.194 and before allows a remote attacker to execute arbitrary code via the from_math_prompt and…

    Affected: fixed in 0.0.195; fixed in 0.0.236.

  • An issue in LangChain v.0.0.231 allows a remote attacker to execute arbitrary code via the prompt parameter.

    Affected: fixed in 0.0.247.

Show all 22 advisoriesShow fewer advisories
  • An issue in Harrison Chase langchain v.0.0.194 allows an attacker to execute arbitrary code via the python exec calls in the PALChain…

    Affected: fixed in 0.0.236.

  • SQL injection vulnerability in langchain before v0.0.247 allows a remote attacker to obtain sensitive information via the SQLDatabaseChain…

    Affected: fixed in 0.0.247.

  • An issue in langchain v.0.0.64 allows a remote attacker to execute arbitrary code via the PALChain parameter in the Python exec method.

    Affected: fixed in 0.0.247.

  • An issue in LangChain before 0.0.236 allows an attacker to execute arbitrary code because Python code with os.system, exec, or eval can be…

    Affected: fixed in 0.0.247.

  • CVE-2023-34541Critical 9.8

    Langchain 0.0.171 is vulnerable to Arbitrary code execution in load_prompt.

    Affected: fixed in 0.0.247.

  • Langchain before v0.0.225 was discovered to contain a remote code execution (RCE) vulnerability in the component JiraAPIWrapper (aka the…

    Affected: fixed in 0.0.225.

  • CVE-2023-29374Critical 9.8

    In LangChain through 0.0.131, the LLMMathChain chain allows prompt injection attacks that can execute arbitrary code via the Python exec…

    Affected: through 0.0.131; fixed in 0.0.132.