# ipython (PyPI) vulnerabilities

8 known vulnerabilities (1 high, 1 medium), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: not known (cve.now hasn't read this package's releases)
- Newest unaffected release: not known without release data
- Registry: https://pypi.org/project/ipython/

## Advisories (8)

### [CVE-2023-24816](https://cve.now/CVE-2023-24816): set\_term\_title command injection in ipython

- Severity: Medium 4.5
- Published: Feb 10, 2023
- Affected: fixed in 8.10.0.

### [CVE-2022-21699](https://cve.now/CVE-2022-21699): Execution with Unnecessary Privileges in ipython

- Severity: High 8.2
- Published: Jan 19, 2022
- Affected: fixed in 5.11; from 6.0.0, fixed in 7.16.3; from 7.17.0, fixed in 7.31.1; from 8.0.0, fixed in 8.0.1; fixed in 6.0.0rc1; from 6.0.0, fixed in 7.16.3; from 7.17.0, fixed in 7.31.1; from 8.0.0, fixed in 8.0.1.

### [CVE-2015-4706](https://cve.now/CVE-2015-4706): Cross-site scripting (XSS) vulnerability in IPython 3.x before 3.2 allows remote attackers to inject arbitrary web script or HTML via…

- Severity: Unrated
- Published: Sep 21, 2017
- Affected: from 3.0.0, fixed in 3.2.0.

### [CVE-2015-4707](https://cve.now/CVE-2015-4707): Cross-site scripting (XSS) vulnerability in IPython before 3.2 allows remote attackers to inject arbitrary web script or HTML via vectors…

- Severity: Unrated
- Published: Sep 20, 2017
- Affected: fixed in 3.2.0.

### [CVE-2015-5607](https://cve.now/CVE-2015-5607): Cross-site request forgery in the REST API in IPython 2 and 3.

- Severity: Unrated
- Published: Sep 20, 2017
- Affected: from 0.12, fixed in 2.4.1; from 3.0.0, fixed in 3.2.3; fixed in 3.2.1.

### [CVE-2015-7337](https://cve.now/CVE-2015-7337): The editor in IPython Notebook before 3.2.2 and Jupyter Notebook 4.0.x before 4.0.5 allows remote attackers to execute arbitrary…

- Severity: Unrated
- Published: Sep 29, 2015
- Affected: fixed in 3.2.2.

### [CVE-2015-6938](https://cve.now/CVE-2015-6938): Cross-site scripting (XSS) vulnerability in the file browser in notebook/notebookapp.py in IPython Notebook before 3.2.2 and Jupyter…

- Severity: Unrated
- Published: Sep 21, 2015
- Affected: fixed in 3.2.2.

### [CVE-2014-3429](https://cve.now/CVE-2014-3429): IPython Notebook 0.12 through 1.x before 1.2 does not validate the origin of websocket requests, which allows remote attackers to execute…

- Severity: Unrated
- Published: Aug 7, 2014
- Affected: from 0.12, fixed in 1.2.0.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/pypi/ipython
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
