Skip to main content
← PyPI

httpie

4 known vulnerabilities (1 high, 1 medium, 1 low), with the versions each affects and the releases that fix them.

Latest release
Not known: cve.now hasn't read this package's releases
Newest unaffected release
Not known without release data
Advisories
4 · 1 high, 1 medium, 1 low
Registry
PyPI

Advisories 4

  • Missing SSL certificate validation in HTTPie v3.2.2 allows attackers to eavesdrop on communications between the host and server via a…

    Affected: fixed in 3.2.3; all versions.

  • Exposure of Sensitive Information to an Unauthorized Actor in httpie/httpie

    Affected: fixed in 3.1.0.

  • CVE-2022-24737Medium 6.5

    Exposure of Sensitive Information to an Unauthorized Actor in httpie

    Affected: fixed in 3.1.0.

  • All versions of the HTTPie package prior to version 1.0.3 are vulnerable to Open Redirect that allows an attacker to write an arbitrary…

    Affected: fixed in 1.0.3; fixed in 1.0.3.