# guardrails-ai (PyPI) vulnerabilities

4 known vulnerabilities (2 critical, 1 high, 1 medium), with the versions each affects and the releases that fix them.

## At a glance

- Latest release: 0.11.0 (Aug 14, 2026): no advisory affects it
- Newest unaffected release: 0.11.0 (Aug 14, 2026), the latest release
- Weekly downloads: 33.3K
- Dependents: 79
- Releases: 106 since 0.1.0 (Mar 13, 2023)
- Registry: https://pypi.org/project/guardrails-ai/
- Releases read: Nov 8, 2026

## Version timeline

Affected versions per advisory, in version order:

- CVE-2026-45758: 0.1.0rc1 to 0.10.0 (0.10.2 is outside it)
- CVE-2026-31233: 0.1.0rc1 to 0.6.7 (0.6.8 is outside it)
- CVE-2024-45858: 0.2.9 to 0.5.9 (0.5.10 is outside it)
- CVE-2024-6961: 0.1.0rc1 to 0.5.0a13 (0.5.0 is outside it)

## Advisories (4)

### [CVE-2026-45758](https://cve.now/CVE-2026-45758): Malicious code in guardrails-ai 0.10.1 (supply chain compromise)

- Severity: Critical 9.6
- Published: Jun 5, 2026
- Affected: through 0.10.1; versions 0.10.1.
- Fixed in 0.10.2 (released Jun 4, 2026, 1 day before disclosure), the first release outside every affected range (no listed fixed version clears them all).
- The latest release, 0.11.0, is not affected.

### [CVE-2026-31233](https://cve.now/CVE-2026-31233): Guardrails AI thru 0.6.7 contains a code injection vulnerability (CWE-94) in its Hub package installation mechanism.

- Severity: Critical 9.8
- Published: May 12, 2026
- Affected: through 0.6.7.
- Fixed in 0.6.8 (released Nov 24, 2025, 169 days before disclosure), the first release outside every affected range (no listed fixed version clears them all).
- The latest release, 0.11.0, is not affected.

### [CVE-2024-45858](https://cve.now/CVE-2024-45858): An arbitrary code execution vulnerability exists in versions 0.2.9 up to 0.5.10 of the Guardrails AI Guardrails framework because of the…

- Severity: High 7.8
- Published: Sep 18, 2024
- Affected: from 0.2.9, fixed in 0.5.10.
- Fixed in 0.5.10 (released Sep 17, 2024, 1 day before disclosure).
- The latest release, 0.11.0, is not affected.

### [CVE-2024-6961](https://cve.now/CVE-2024-6961): XXE in Guardrails AI when consuming RAIL documents

- Severity: Medium 5.9
- Published: Jul 21, 2024
- Affected: fixed in 0.5.0; fixed in 0.5.0.
- Fixed in 0.5.0 (released Jul 17, 2024, 4 days before disclosure).
- The latest release, 0.11.0, is not affected.

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/packages/pypi/guardrails-ai
Site guide for agents: https://cve.now/llms.txt
Uses NVD data; not endorsed by NVD.
